修改WP Cleaner短标签语句

之前写过一篇这个插件的文章WP Cleaner 删除wordpress不再需要的修订版,但是自从某次升级以后变无法使用这款插件了,我一直以为是插件的问题,并且作者也发出了一个修正版本,但是情况依然没有改变,我还是无法使用。

这两天找了找其他的清理插件,效果没有这个理想还是想用这款插件,于是耐下心来看了看插件的代码,结果发现并不是大问题,因为我的空间不在支持短标签了,而插件是使用的短标签“<? ”我只需要改成“<?php ”即可了,粗略看了下代码使用了三次替换来处理这块。

第一,把代码里的“<?=”替换为“<?php echo ”
第二,把“<?”替换为“<?php”
第三,把“<?phpphp”替换为“<?php”

完成这三次替换保存代码即可在关闭短标签的状态下使用了。

插件官方地址:http://www.jiangmiao.org/blog/138.html

本站提供修改版下载地址:http://www.box.net/shared/sarkgk9ma2

PS:其实这个只是代码写作习惯问题,建议插件作者也处理下这块,毕竟运行环境有时候不用用户能够操作的,而且一个良好的习惯也是有必要的。

发表评论

邮箱地址不会被公开。 必填项已用*标注